Lake St. Clair Fishing Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
189 Posts
i have an 1989 50 horse power Force motor that just started overheating recently when i have the throttle down far. when it overheats, an alarm sounds and i shut it off and there is a good amount of smoke coming out the back. the thing that bothers me is that the motor runs fine at an idle speed or going with the throttle half way down. any suggestions? someone told me i might need a new water pump or a new impeller. suggestions???? i idled for about 3 miles with no problem after it overheated today!!

thanks!
 

·
Registered
Joined
·
1,461 Posts
If it's been more than a couple of years since you last changed the impeller, you're way over due. That's the likely culprit...
 

·
Premium Member
Joined
·
1,657 Posts
QUOTE(Capn Ken @ Jul 5 2009, 11:05 PM) <{POST_SNAPBACK}>If it's been more than a couple of years since you last changed the impeller, you're way over due. That's the likely culprit...

Agreed, impellers lose efficiency over time and it could still be pumping some water, but not enough to keep the engine cool under a heavy load.
 

·
Registered
Joined
·
1,043 Posts
QUOTE(4_winns_fan @ Jul 6 2009, 05:42 PM) <{POST_SNAPBACK}>QUOTE(Capn Ken @ Jul 5 2009, 11:05 PM) <{POST_SNAPBACK}>If it's been more than a couple of years since you last changed the impeller, you're way over due. That's the likely culprit...

Agreed, impellers lose efficiency over time and it could still be pumping some water, but not enough to keep the engine cool under a heavy load.


This would be my guess.
 

·
Registered
Joined
·
2,874 Posts
My 150 Force spits and gurgles water out the exhaust. Very hard to tell if its circulating enough water by looking at it. Change the impellor.
 
1 - 6 of 6 Posts
Top